鱼木优品
鱼木优品
我的世界 rcon 使用示例及教程

我的世界RCON 使用示例及教程

 

作为一名mc腐竹, 管理好服务器也是一件头疼的事
在搭建服务器时必定会接触的配置文件 server.properties 配置文件中
有着这么一个配置项 enable-rcon=false #是否开启 rcon 监听
通过各种百科都可以知道:  RCON 是一种允许服务器管理员远程执行 Minecraft 命令的协议。在 1.9 pre4 中引入,它基本上是 Minecraft 的 Source RCON 协议的实现。

 

于是, 我们为什么不用机器人在群里发送相应指令来管理服务器呢?
这也省下了我们去登陆后台的时间(就几秒钟)
说整就整, 打开服务器配置文件, 将
enable-rcon=false 改为 enable-rcon=true
添加(/修改)配置项 rcon.port=[监听端口]
添加(/修改)配置项 rcon.password=[rcon密码]

1.打开易语言(问就是方便), 新建 Windows 易语言模块, 引用精易模块

1.1 代码截图

代码总览
RCON_连接代码预览
RCON发送与接收代码预览

 

首先声明变量 ‘客户’ 类型为 ‘网络客户端’ ,可以是 程序集变量 也可以是 全局变量

我这里声明的是 程序集变量

.版本 2
.支持库 sock

.程序集变量 客户, 网络客户端

.版本 2
.支持库 sock
.支持库 eAPI

.子程序 RCON_连接, 整数型, 公开, 返回值: 1成功   -1密码错误   -2无连接   -3意外错误
.参数 ip, 文本型
.参数 port, 整数型
.参数 psw, 文本型
.局部变量 post, 字节集
.局部变量 back, 字节集
.局部变量 temp_bool, 逻辑型

.判断开始 (客户.连接 (取IP地址 (ip), port))
    post = 到字节集 (到字节 (到整数 (取文本长度 (psw) + 9))) + { 0, 0, 0, 0, 0, 0, 0, 3, 0, 0, 0 } + 到字节集 (psw) + { 0 }

    .判断开始 (客户.发送 (post, 0))
        back = 客户.接收 (0, temp_bool)
        .判断开始 (temp_bool)
            .判断开始 (back = { 10, 0, 0, 0, 0, 0, 0, 0, 2, 0, 0, 0, 0, 0 })
                返回 (1)
            .判断 (back = { 10, 0, 0, 0, 255, 255, 255, 255, 2, 0, 0, 0, 0, 0 })
                返回 (-1)
            .默认
                返回 (-3)
            .判断结束

        .默认
            返回 (-3)
        .判断结束

    .默认
        返回 (-2)
    .判断结束

.默认
    返回 (-2)
.判断结束


.子程序 RCON_发送, 文本型, 公开, 成功返回 命令执行后,服务器控制台返回的消息; 失败返回 null
.参数 ins, 文本型

.如果真 (取文本左边 (ins, 1) = “/” 或 取文本左边 (ins, 1) = “\”)
    ins = 取文本右边 (ins, 取文本长度 (ins) - 1)
.如果真结束
ins = 编码_gb2312到utf8 (ins)
客户.发送 (到字节集 (到字节 (到整数 (取文本长度 (ins)) + 9)) + { 0, 0, 0, 0, 0, 0, 0, 2, 0, 0, 0 } + 到字节集 (ins) + { 0 }, 0)
返回 (RCON_接收 ())


.子程序 RCON_接收, 文本型, , 请勿直接调用
.局部变量 back, 字节集
.局部变量 temp_bool, 逻辑型
.局部变量 temp_byte, 字节集, , "0"
.局部变量 temp_str, 文本型

back = 客户.接收 (0, temp_bool)
.判断开始 (temp_bool)
    temp_byte = 分割字节集 (back, { 0 }, )
    temp_str = 编码_utf8到gb2312 (到文本 (temp_byte [13 - 取字节集长度 (temp_byte [1])]))
    返回 (temp_str)
.默认
    返回 (“null”)
.判断结束


.子程序 RCON_断开, , 公开, 断开与RCON的连接

客户.断开 ()

1.2编译为模块

2.新建Windows窗口程序(/Windows动态链接库), 引用1.2编译的模块

2.1

 

RCON使用示例

 

以上便是mc rcon的食用方法了, 模块部分代码来自互联网, 并做部分修改编译成了现在的模块, 侵删
模块下载地址: https://f.hloli.cn
想用机器人一键管理? 来康康NaNBot吧: https://d.nanbot.net/

 

文章原创地址:银月のBlog

你需要先 登录 才能发表评论。

鱼木优品

我的世界 rcon 使用示例及教程
我的世界RCON 使用示例及教程   作为一名mc腐竹, 管理好服务器也是一件头疼的事 在搭建服务器时必定会接触的配置文件 server.properties 配置文件中 有着这么一个配置项 enabl…
扫描二维码继续阅读
2020-07-12